How-To Create and Consume a Web Service in C# and ASP.NET

Create anew Visual Studio project

I loxltc-an|

b Recent NET Framework 3.5 « Sortby: Default v 33 1= | Searchinstalled Te P~
4 Installed s
ASP.NET Empty Web Applicat... Visual C& Type: Visual C#
4 Templates - An empty project for creating an
4 Visual C# application with & Web user interface
b Windows
Web
Android
Cloud
| Extensibility
10S
LightSwitch
Office/SharePoint
Silverlight
Test
WCF
Workflow -
b Online 1k het nho mpl
Nome: WebService
Location: E\CodeSamples\ - | Browse...
Solution name: WebService (] Create directory for solution
[7] Add to Source Control

Right click on the project and select Add > New Item > Web Service (ASMX)
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Click here to go online and find templates
Name: WebService.asmx

See that the following code gets automatically generated in WebService.asmx.cs

WebService.asmx.cs

1
2 using System.Web. Services;
2 namespace WebService
{

5 /// <summary>
6 /// Summary description for WebService
7 /// </summary>
8 [WebService (Namespace = "http://tempuri.org/")]
9 [WebServiceBinding (ConformsTo = WsiProfiles.BasicProfilel 1)]

[System.ComponentModel. ToolboxItem(false) ]
10 // To allow this Web Service to be called from script, using ASP.NET AJAX, uncomm
11 // [System.Web.Script.Services.ScriptService]

public class WebService : System.Web.Services.WebService
12 {
13
14 [

WebMethod]
15 public string HelloWorld ()
16 {
17 return "Hello World";
}

18

}
19 }


http://tempuri.org/
https://www.technical-recipes.com/wp-content/uploads/2017/08/webservice2.jpg

On compiling and running the project you are directed to a web browser that points to your service
containing the single ‘HelloWorld’ method:

C 0 @® localhost:52298/WebService.asm» Wi ‘
322 Apps Imported From I [} TFS V6 m TESIDT Powers - Ta IDT » Other bookmarks

The following operations are supported. For a formal definition, please review the Service Description.

l WebService
|

e HelloWorld

This web service is using http:/ /tempuri.org/ as its default namespace.

Recommendation: Change the default namespace before the XML Web service is made
public.

Each XML Web service needs a unique namespace in order for client applications to distinguish it from other ‘
services on the Web. http://tempun.org/ is available for XML Web services that are under development, but
published XML Web services should use a more permanent namespace.

Your XML Web service should be identified by @ namespace that you control. For example, you can use your
company's Internet domain name as part of the namespace. Although many XML Web service namespaces
look like URLSs, they need not point to actual resources on the Web. (XML Web service namespaces are URIs.)

For XML Web services creating using ASP.NET, the default namespace can be changed using the WebService
attribute’s Namespace property. The WebService attribute is an attribute applied to the class that contains
the XML Web service methods. Below is a code example that sets the namespace to
"http://microsoft.com/webservices/":

C=

[WebZexvice (Namespace="hetp://microscofs.com/vebrexvices/ )]
public clase MyWeblexzvice |

// implemantaticon
)

Visual Basic

<Weblexvice (Namespace:®="hoep://microsofc.com/vwebzexrvices/")> Fublic Class MyWebService
' implementation

End Class

C++

[Febfezvice (Namespace®"hesp://miczescfs.com/webaesvices/ ) ]
public zef class MyWebfervice {
// implemensaticn

For more details on XML namespaces, see the W3C recommendation on Namespaces in XML.

For more details on WSDL, see the WSDL Specification.

For more details on URIs, see RFC 2396.

And when you click on the ‘HelloWorld’ link you are directed to the page to invoke the selected operation:
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< C ) | © localhost:52298/WebService.asmx?op=HelloWorld %| @

Apps Imported FromIE [} TFSV6 m TFS IDT Powers - Ta IDT » Other bookmarks

WebService

Click here for a complete list of operations.

HelloWorld

Test

To test the operation using the HTTP POST protocol, click the ‘Invoke' button.

Invoke

SOAP 1.1

The following is a sample SOAP 1.1 request and response. The placeholders shown need to be replaced
with actual values.

F08T [Weblezvice.asmx MITF/1.1

Hosz: leocalhost

Content~Iype: texs/>=ml; charsez®usf-$
Content~length: length

30APActicn: “hetp://tempuri.oxrg/HelloWozld"

<7Txml vezzica="1.0" encoding="usf~I"1>
<scap:Envelcope xmins:xsi®heep://vwe . »i.oxg/2001/ 00 chena~inatance” xulns:xsd="heop: /[ . ¥3 . 02g/200
<scap:Body>
<MelloWorld smins®“heeop://cempuri.oczg/™ />
</zcap:Body>
</20cap:Envelope>

HITP/1.1 200 OK
Content-Iype: text/xml; charsev=utf-§
Content-length: length

<Pl verszica="l. 0" enccding=vunf-ETI>
<scap:Envelope xmina:xsi®m“heop://vwe. %3.0xg/2001 /00 Schena-instance™ xming:xsd" heop://www w3 . 02g/200:
<scap:Bady>
<HelloWorlidResponse xmins®“hesp://cempuri. czg/">
<HelloWorlidResuls>=tring</HelloWorlidResuls>
</HellcWorldResponsze>
</scap:Body>
</scap:Envelope>

SOAP 1.2

The foliowing i1s a sample SOAP 1.2 request and response. The placeholders shown need to be replaced
with actual values.

FO8T /WebService.asmx MITF/1.1

Heosz: localheoss

Contenc-Type: application/scapxml; charses=uci-2
Content-length: length

Clicking Invoke then directs you to the XML file:
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C ) | ® localhost:52298/WebService.asmx/HelloWor o
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This XML file does not appear to have any style information associated with 1t. The document tree
| is shown below:

<string xmlns="http://tempuri.org/">Hello World</string>

Add two additional services, Square and SquareRoot to WebService.asmx.cs:

WebService.asmx.cs

1
2 using System;
3 using System.Web. Services;
4
namespace WebService
> {
6 /// <summary>
7 /// Summary description for WebService
8 /// </summary>
9 [WebService (Namespace = "http://tempuri.org/")]
[WebServiceBinding(ConformsTo = WsiProfiles.BasicProfilel 1)]
10 -
11 [System.ComponentModel. ToolboxItem(false) ]
// To allow this Web Service to be called from script, using ASP.NET AJAX, uncommg

12 // [System.Web.Script.Services.ScriptService]
13 public class WebService : System.Web.Services.WebService
14 {
15

[WebMethod]
i? public string HelloWorld ()

{
18 return "Hello World";
19 }
20
21 [WebMethod]
29 public double Square (double x)

{
23 returnx * x;
24 }
25
26 [WebMethod]
27 public double SquareRoot (float x)

{
28 return Math. Sgrt (x);
29 }
30 }
31 !
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Rebuild and re-run your project and notice that two additional services are displayed:

C O | @ localhost:52298/WebService.asmx w|

1* Apps Imported FromIE [ TFSV6 [ TFSIDT Powers - Ta DT » Cther bookmarks

WebService

The following operations are supported. For a formal definition, please review the Service Description.

e HelloWorld

e Square

e SquareRoot

This web service is using http://tempuri.org/ as its default namespace.

Recommendation: Change the default namespace before the XML Web service is made
public.

Each XML Web service needs a unique namespace in order for client applications to distinguish it from other
services on the Web. http://tempun.org/ is available for XML Web services that are under development, but
published XML Web services should use 3 more permanent namespace.

Your XML Web service should be identified by @ namespace that you control. For example, you can use your
company's Internet domain name as part of the namespace. Although many XML Web service namespaces
look like URLs, they need not point to actual resources on the Web. (XML Web service namespaces are URIs.)

For XML Web services creating using ASP.NET, the default namespace can be changed using the WebService
attribute’'s Namespace property. The WebService attribute is an attribute applied to the class that contains
the XML Web service methods, Below 15 a code example that sets the namespace to
"http://microsoft.com/webservices/":

C=

[Webfezvice (Namespace="hetp://microscfs.com/vebsesvices/") ]
public class NyWeblezvice {
[/ izplementasicn

Visual Basic

<Weblezvice (Namespace:="hesp://miczcscss.conm/vebsesvices/")> Fublic Class MyWeblezvice
' implementasion
End Class

C++
[Weblezvice (Namespace="hetp://miczoscfs.con/vebrasvicen/") ]
public zef clasz NyWeblexzvice |
// izplementaticn
=

.

For more details on XML namespaces, see the W3C recommendation on Namespaces in XML,

Click on one of the new examples, SquareRoot for example, and invoke this:
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< C O | @ localhost:52298/WebService.asmx?op=SquareRoot w| ¢

it Apps Imported FromIE [ TFS V6 m TFSIDT Powers - Ta IDT » Other bookmarks

WebService

Click here for a complete list of operations.

SquareRoot

Test

To test the operation using the HTTP POST protocol, click the 'Invoke’ button.
Parameter Value

XKs 64| ‘
Invoke

SOAP 1.1

The following is a sample SOAP 1.1 request and response. The placeholders shown need to be replaced
with actual values.

FOST /Weblfexvice.asmx HITP/1.1

Hoszt: localhoss

Content-Iype: text/xml; charses=usf-2
Content~length: length

30AFAction: “heosp://tempuri.oxg/3quareRcot™

<7xml vexrsicon="l1.0" enccding="usf-2"1>
<scap:Envelope xmlns:xsi="hesp://vww. . vd.oxg/2001/ 00 Schena-instance™ xnlns:xsd="hesp://ww.»3. 02g/200!
<scap:Becdy>
<3guazeRcos xminam“hesp://cexpusi.ozg/">
<x>£loan</x>
</SquazeRoos>
</scap:Bady>
</scap:Envelope>

MITP/3.2 200 OK
Content=Iype: teaxt/xml; chazset®ussf-2
Contenc~length: length

<?xmi veraiocn®*l.0" enccding®“usf-8"7>
<scap:Envelope xmins:xsi®“"heop://www.w3.oxg/2001/00 8chema~instance” xmlins:xad® heep://vww. wd oxg/200!:
<scap:Bedy>
<3quareRocctResponze xmins="heep://tempuri.oxg/">
<2quareRcctResuls>double</2quareRootResules>
</3quareRcotRezponsze>
</scap:Bedy>
</2cap:Envelope>

SOAP 1.2

The following 15 a sample SOAP 1.2 request and response. The placeholders shown need to be replaced

Giving use the answer in XML format as shown:
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C ) | © localhost:52298/WebService.asmx/SquareRoot W
% Apps Imported FromIE [ TFSV6 [&] TFSIDT Powers - Ta! 10T » Other bookmarks

This XML file does not appear to have any style information associated with 1t. The document tree
1s shown below.

<double xmlns="http://tempuri.org/">8</double>

Consuming the web service
Create anew Console Application in your solution

Add New Project 12 e |

b Recent NET Framework 3.5 ~ Sortby: Default vl §3° 3= Seorchinstalled Te P~
4 Installed cx
| | Windows Forms Application  Visual C# = Type: Visual C#
-~
4 Visual C= - A project for creating a command-line
b Windows I "] WP Application Visual C& application
Web o _
Android ﬁ Console Apphication Visual (=
Cloud
c.
Bxtensibility _] Shared Project Visual C#
108
3 2 (<
LightSwitch Q:ﬁl Class Library (Portable for iOS.., Visual C#
Office/SharePoint v
. :l
Silverfight nﬁl Class Library Visual C=
Test 5
WCF $
Silverlight lication Visual C=
Workflow e
b Visual Basic ' C .
h t 3
Visusl F& & Sitverlight Class Library Visual C
b Visual C++ ce
WCF Service lication Visual C=
Windows Installer XML @ Apph o
ml&m’ - A Lo L T [N T T Vet M- i
b Online lick her nline and fingd templ
Name: WebServiceConsumer
Location: E\CodeSamples\WebService - | Browse...

Lok J| conce

Right click your project and select Add > Service Reference...

Rename the namespace if you wish:
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Add Service Reference =)
To see a list of available services on a specific server, enter a service URL and click Go. To browse for available
services, click Discover.

Address:
v | Go | Discover "
Services: Operations:
Namespace:
ServiceReference
Adyanced.. [ ok || conces |

Click on the Advanced button.
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Service Reference Settings

Client

Access level for generated classes: [Publit

["] Allow generation of asynchronous operations
Generate task-based operations

@ Generate asynchronous operations

Data Type
[ Always generate message contracts
Collection type: [System.Anay v ]
Dictionary collection type: | System.Collections. Generic.Dictionary v

Reuse types in referenced assemblies
@ Reuse types in all referenced assemblies

) Reuse types in specified referenced assemblies:

&' mscorlib

&' System

O System.Core

& System.Data

"] & System.Data.DataSetExtensions

= = . =

Compatibility

Add a Web Reference instead of a Service Reference. This will generate code based on .NET Framework 2.0

Web Services technology.

| Add Web Reference... |

Click Add Web Reference
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Add Web Reference i @
L JRpe————

Navigate to a web service URL and click Add Reference to add all the available services.

C IR

URL: .

« Web services found at this URL:

Start Browsing for Web Services

Use this page as a starting point to find Web services. You can dick the links below, or type a
known URL into the address bar.

Browse to:
= Web services in this solution

= Web services on the local machine
-

< > ¥ I ne
Query your local network for UDDI servers,

Add Reference

Click the link that says to browse to services in this solution... Observe that it discovers the web service we
earlier created for this solution:

[ Add Web Reference i =)
i | R ——

Navigate to a web zervice URL and click Add Reference to add all the available services.

|
O® %o
URL: * m
« Web gervices found at this URL:

Web Services in this Solution

The Wb services svalable n this solubon are ksted bedow. Cick the service Ink to browse that

service,

Services Project URL

WebService WebService WebService. asmx

Add Reference
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Click on this service and see that the range of service methods is displayed:

Add Web Reference S el

Navigate to a web service URL and click Add Reference to add all the available services.

CP® %OB

URL: http://localhost:52298/ WebService.asmx - =

| webserviee |

The following operations are supported. For a formal definition, please review
the Service Description,

m

e HelloWorld
- g’![’]ff‘

* SquarcRoot

This web service is using http:/ /tempuri.org/ as its default
namespace.

Recommendation: Change the default namespace before the XML
. Web service is made public.

Each XML Web service needs a unique namespace in order for client
apphcations to distinguish t from other services on the Web. hitp://tempuri.org/
is available for XML Web services that are under development, but published
XML Web services should use a2 more permanent namespace.

Your XML Web service should be identified by a namespace that you control. For

example, you can use your company's Internet domain name as part of the

nammarnnrs Albhacinbh saang YMEL Wak ramiase namarnascar anl Lba 1D e thase
« m »

-

———

Web services found at this URL:

1 Service Found:

- WebService

Web reference name:

localhost

[ Add Reference ]

[ H

=

Rename the Web reference name to your preference:

-
Add Web Reference 8 el

Navigate to a web service URL and click Add Reference to add all the available services.

O OB

URL:  http://localhost:52298/ WebService.asmx - 1

e ——

The following operations are supported. For a formal definition, please review
the Service Description,

m

e HelloWorld
® Squarc

® SquarcRoot

This web service is using http:/ /tempuri.org/ as its default
namespace.

Recommendation: Change the default namespace before the XML
. Web service is made public.

Each XML Web service needs a unique namespace in order for client
apphcations to distinguish t from other services on the Web. hitp://tempuni.org/
is available for XML Web services that are under development, but published
XML Web services should use a2 more permanent namespace,

Your XML Web service should be identified by a namespace that you control, For

example, you can use your company's Internet domain name as part of the

namarnnre Albhacnh saang YA Wah ramare namarnacar lanl Llba 1D e thae
‘ m »

-

—

Web services found at this URL:

1 Service Found:

- WebService

Web reference name:

WebServices|

|

Add Reference |
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Click Add Reference.

Observe the Web References folder containing WebServices is created as shown:

Solution Explorer
SRANI RS- R

Search Solution Explorer (Ctrl+;)

Solution 'WebService' (2 projects)
P &) WebService
4 WebServiceConsumer
4 M Properties
¢# Assemblylnfo.cs
b §iF Settings.settings
p =W References
Service References
4 Web References
g WebServices
¢ app.config
P ©* Program.cs

Set the console application as your startup project:
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Solution Explorer
Coe-sea@| p -

Search Solution Explorer (Ctrl+;)

fa] Solution 'WebService' (2 projects)
b &) WebService

b WebServiceConsumer

Build
Rebuild

Clean

View »
Analyze 4
Publish...

Publish as Azure WeblJob...

v &

Scope to This
New Solution Explorer View

Build Dependencies »

Add »
Manage NuGet Packages...

o -2

Set as StartUp Project
Debug 4

Update Program.cs in your console application to consume the referenced web service.

In this example to find and display the square root of 64:

Program.cs

1 using System;

2 using WebServiceConsumer.WebServices;

3

4 namespace WebServiceConsumer

{

5 internal staticclass Program

6 {

7 private staticvoidMain (string[] args)
{

8 var service = new WebService();

10 Console.Write ("Square root of 64 = {0}", service.SquareRoot (64));

11 }
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13}

Giving the following console output when run:

~

B file:///E:/CodeSamples/WebService/WebServi... | = E ‘i}%—]

Square root of 64

Courtesy: https://www.technical-recipes.com/2017/creating-and-consuming-a-web-service-in-c-net/
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